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	Thank you for your interest in Task Manager for Excel.  This program is shareware and can be used at no cost for a thirty-day trial period.  If you like it and wish to continue using it, you must register it.  Registered users receive instructions for disabling the initial welcome screen, free technical support and notification of new releases as well as one free upgrade.  To register the program, fill out the registration form at the end of this file (page 6) and mail it along with the $2.00 registration fee to the address shown on the form.  Feel free to distribute or upload the program, but please distribute it in its complete unaltered form as the self extracting archive file TMXL15.EXE or all of its separate components.  Thank you very much for your cooperation.





Introduction





	Task Manager for Excel is an application written for Microsoft Excel for Windows 95 that simplifies task management by providing a prioritized to do list with built in scheduled reminders.  Its user-friendly, straight forward interface makes the program fast and easy to learn and use.  Although you most likely will not need any instructions, a complete description of the program and all of its functions are provided below.  It was written using Visual Basic for Applications in Excel for Windows 95 and has been tested and is completely compatible with both Excel 95 and Excel 97.  For compatibility purposes, the Task Manager for Excel workbook is in the Excel 95 file format.  However, if you are using Excel 97, you should save it in the newer Excel 97 format.





Installation





	Task Manager for Excel is easy to install.  Simply execute the TMXL15.EXE file and extract the resulting TMXL15.XLS file to the folder of your choice.  Documentation is provided in a Word document - TMXL15.DOC, which can be viewed with the Word Pad applet that comes with Windows 95  You can rename the TMXL15.XLS file if you desire.





	Task Manager for Excel was designed to run continuously while Excel is running.  It can be placed in the Excel startup folder so that it opens with Excel and provides you with easy access to all your tasks and reminders.  It can be hidden and unhidden with a click of the mouse so it doesn't interfere with your other work.  The program remains completely functional even when it's hidden.





Instructions





	Task Manager for Excel is an Excel workbook that contains the main Task Manager worksheet, as well as hidden VBA modules and dialog sheets.  This worksheet furnishes the complete program interface with the buttons at the top of the screen providing access to all the functions.  There is also a "Project" menu added to the main Excel menu bar that can be used to access all the functions.  The Task Manager worksheet uses Excel's built in outline capabilities to group your various tasks by project.  Each project can be expanded or collapsed to view or hide the various tasks associated with it.





	The first time you open the Task Manager for Excel workbook, the welcome dialog box will be displayed.  Please heed the advice in the dialog box and register the program.  It will help provide useful ideas for future enhancements, and registered users will be provided with technical support and one free upgrade.  Click OK to continue.  The main Task Manager worksheet will be displayed.  It contains a series of buttons along the top of the screen with the empty worksheet below.  The "Miscellaneous" project is already present with a single task reminding you to register this program.  The Miscellaneous project cannot be deleted.  Registered users will receive instructions on how to delete the registration reminder task, otherwise, it cannot be deleted either.





	If you are using a standard 640 x 480 VGA display, the Task Manager worksheet will occupy the total width of your screen.  If you are using a higher resolution display and want to make the display larger, you can adjust the zoom setting so that the worksheet occupies the full width of your screen.  Simply select Zoom from the View menu and enter a custom zoom value.  You will need to experiment to find the correct setting.  Usually 125% works well with an 800 x 600 resolution.  Enter a higher number for higher resolutions.





	Task Manager for Excel is very user friendly and operates entirely from the tool buttons or Project menu.  Most of the functions are self explanatory but a detailed description of each of them is provided below.





	The New Project function displays an input box that lets you enter the name of a new project.  Type in the project name and click OK or hit Enter to create a new project.





	The Add function displays a dialog box that provides for entry of a new task.  This dialog box is displayed below.  Enter a task description in the Task field and select a project from the Project drop down list.  The current project will be displayed by default, but you can select from any of the projects listed.  Date and time entries are optional unless the "Set Reminder" check box is checked, then at least a date is required.  If "Set Reminder" is selected, a message box will be displayed at the date and time indicated reminding you of the specific task.  (Task Manager for Excel must be running for this to occur.)  All task entries will appear in red if the date and time indicated has passed, even if "Set Reminder" is not selected.
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	You can enter a task priority from 1 to 9 and mark a task as completed by checking the "Completed" check box.  Completed tasks are automatically assigned a priority of 10.  You can also enter additional information or comments in the "Note" field.  This information will then be entered as a cell note in the task entry on the main worksheet.  The note will be displayed whenever the mouse pointer is held over the associated task.  Notes are indicated by a small red dot in the upper right corner of the task description cell.





	Once you've entered all the information pertinent to your specific task, click OK to enter the task in the worksheet.  The task will be added to the project that you selected.  Tasks with reminders will have a symbol of a bell beside them, while completed tasks will have a check mark and be displayed in green.  Past due tasks are displayed in red.





	The Edit function allows you to edit a task or project name.  Just place the cell cursor anywhere in the row of the task or project you wish to edit, and click the Edit button (or select Edit Project/Task from the Project menu).  If you have selected a project to edit, an input box with the project name will be displayed.  Edit the project name and click OK to enter the new name or click Cancel to leave it unchanged.  If you have selected a task to edit, the task dialog box shown above will once again be displayed.  You can enter or change the task information as described above.





	The Delete function will delete the selected task or an entire project if a project is selected.  You will be prompted with a warning messages if you try to delete a project, asking you to confirm the deletion.  You will not be warned before deleting a task however, so exercise caution as you will not be able to undo the deletion.





	The arrow buttons increase or decrease a task's priority, while the Completed button marks a task as completed.  To unmark a completed task, you must use the Edit function and deselect the Completed check box.





	The Expand All and Collapse All buttons expand or collapse all the projects in the worksheet to show or hide their associated tasks.  You can expand or collapse individual projects by clicking on the + or - sign in the border to the left of the project.  The Hide button hides the Task Manager for Excel workbook.  (You can also hide it using the Hide command on the Project or Window menu.)  The program remains functional even while hidden, and will still display reminder alarms.  The Project menu remains displayed unless Excel is running without an open workbook.  You can add new projects or tasks and use the Print functions while it is hidden, but the Edit Project/Task, Mark Completed, and Delete menu items are disabled.  To unhide the program, use the Unhide command from the Project menu.  (You can also use the Unhide command on the Window menu or, if there are no open workbooks, use the Unhide command on the File menu.)





	Selecting the Print function will display the following dialog box.  You can select from three printing options:  printing the entire worksheet as shown, printing the entire worksheet with the projects all expanded to show all their tasks, or you can print just a single project and its associated tasks.  If you just want to print a single project, a drop down list is available for selecting the project you want to print.  Select the printing option you desire and click OK.  If you would like to preview the print job, select the Preview check box.
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	The Options function allows you to specify whether you want to hide the Task Manager worksheet when starting the program and also whether you want to save the Task Manager worksheet automatically when closing it.  By selecting both these options and placing Task Manager for Excel in your Excel startup folder, you can have it running continuously in the background while Excel is running and any changes will automatically be saved when you exit the program.
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	There are two additional functions which are only accessible from the Project menu.  Registration allows you to enter the registration number supplied when you register the program, while Welcome displays the Welcome dialog box.  Once the program is registered, the Welcome dialog box will no longer be displayed at startup and you will be able to delete the "Register Task Manager for Excel" reminder task.








General Information and Comments





	In order to make Task Manager for Excel easily customizable, the Task Manager worksheet was left unprotected.  This allows you to customize it if you wish to change colors or fonts, etc.  It also allows the user to expand and collapse the project outline as needed.  However, please note that the entire column B uses the Symbol True Type font to display the completed check marks and the entire column D uses the Wingdings True Type font to display the reminder bell symbol.  These fonts are included with Window 95.  If these fonts are deleted from your system or you change the fonts in column B or D, the check mark and reminder bell will no longer be displayed correctly.





	You may have already noticed that you cannot enter, edit or delete data directly in the worksheet.  This protection is added to preserve the integrity of the Task Manager worksheet and outline structure.  Use the Edit and Delete functions instead.  There are some obvious ways around these restrictions, but it is not recommended that you use them.





	Task Manager for Excel has some minor limitations concerning the number of tasks and reminder events that it can store.  You are limited to approximately 2500 tasks and 250 reminder events.  Please let me know if you find these numbers too limiting.





	If more than one row is selected when performing a function, that function will only be performed on the row where the active cell cursor resides.  For example, if you click the Delete button and three separate tasks are selected, only the task where the active cell cursor is located will be deleted.





Technical Support





	Registered users are entitled to free technical support via E-mail and U.S. Mail.  If you have a problem or question, please do not hesitate to contact me at the address on the registration form or at one of the E-mail addresses below.





	E-mail:  dannyi@compuserve.com or dannyi@aol.com





Also, check out our web site for a host of other Excel shareware:





	http://ourword.compuserve.com/homepages/dannyi
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Send to:  Daniel J. Ireland


101 East Crossbow Lane


Slippery Rock, PA 16057





		Name:			______________________________


		Address:      		______________________________


		City:			______________________________


		State & Zip 		______________________________


		E-mail Address:		______________________________


										


				Product Registered:	Task Manager for Excel	


				Version Registered:	1.5





IMPORTANT:  I have read the terms of use and distribution and agree to abide by their terms and restrictions.
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